Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD/aarch64 on 8 GB Raspberry Pi 4B?

I was successfully able to use the RPi UEFI 1.14 firmware release to boot a Raspberry Pi 4B 8GB model when disabling the 3 GB limit. I was also able to reboot successfully (several times) after initial booting.

I did not use the HEAD/latest image because it seemed to point to an older release (from 3rd June). Your NetBSD identifies as "NetBSD 9.99.64 (GENERIC64) #0: Wed Jun 3 07:06:18 UTC 2020" whereas mine is later: "NetBSD 9.99.65 (GENERIC64) #0: Mon Jun 8 22:52:09 UTC 2020".

Maybe a later image might work for you, too?

I thought that, too, and tried a kernel from today's sources, but got the same results.

Then I tried the RPI_EFI.fd Paul sent me, and it worked just fine:


A diff of the hexdumps of both my non-working RPI_EFI.fd and Paul's show a LOT of differences. Can anyone guess at why this might be?

John Klos

Home | Main Index | Thread Index | Old Index