Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Issues with installer on 9.0 RC1's rpi_inst.img


I'm very new to NetBSD, apologies if these are stupid observations, but
I hit some issues with trying to set up a Pi Zero W using
rpi_inst.img.gz for 9.0 RC1 - and I hope the feedback might prove

After configuring the disklabel the installer was unable to write it to
the SD card - the error message show in the installer seemed to just be
the help message for disklabel. I *think* it was because the disk type
it wanted to use ("STORAGE DEVICE" - I'm not sure where this came from)
contains a space and the space wasn't escaped so disklabel saw too many

I was able to manually write out the disklabel from the temporary file
(putting quotes round "STORAGE DEVICE"), but only if I first ran
disklabel interactively and used the "A" command to grow the disklabel
to the size of the SD card. Otherwise the disklabel was sized to the
installation image and the new label layout extends past the original
image size.

Lastly, in frustration I tried to delete and recreate the MS-DOS
partition, which the installer let me configure but when applying it
crashed because it wanted to run "newfs_msdos" to format the partition,
but this is not present on rpi_inst.img - so the installer bailed
because the command could not be run.

Eventually I gave in and wrote 9.0 RC1's rpi.img (pre-installed
filesystem) to the SD card, which worked fine but ideally I'd have
liked more control over the installation.

I'm up and running now, so this is purely for information/feedback.

With regards,


Home | Main Index | Thread Index | Old Index