Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Dockstar boots - was Re: Dockstar question


On Wed, Jun 15, 2011 at 09:24:48PM -0700, Andy Ruhl wrote:
-> I disabled a lot of stuff in /etc/rc.conf, and my dockstar booted with
-> a kernel built yesterday. Here's what I did:
-> #sshd=YES
-> sshd=NO
-> #ntpdate=YES
-> ntpdate=NO
-> #apache=YES
-> apache=NO
-> postfix=NO
-> update_motd=NO
-> (I have telnet enabled)
-> I then enabled sshd, ntpdate, and apache and started them with no problems.
-> I tried to reboot the machine, and it seems like it panicked at reboot
-> because it never came back.

I have also seen this.  This second reboot seems to have marked the filesystem 
dirty and cause an fsck.  The fsck triggers a kernel panic and drops to the
debugger.  I'll try to reproduce it tonight and get a backtrace.


-> I tried to reboot it again and I think it panicked before going down
-> again. I wonder if update_motd really allowed this kernel to boot?
-> So, this is some progress. I still need to see if there is any
-> evidence of a problem with a serial cable at some point.

After successfully booting, I tried to edit /etc/motd with vi and it locked
up when I saved.  Interestingly, all the filesystem writes to /var/run and
/var/log don't cause the system to lock up.

Will install Slackware for food.
 6:20AM  up 114 days, 21:41, 1 user, load averages: 0.00, 0.12, 0.18

Attachment: pgpYXTySqz0bb.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index