Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [Fwd: NSLU2 builds and boots, but seems to disappear when running /sbin/init]

Thanks for responding.

Since I made the rookie mistake of sending my last two posts in html format, I've had a few days to play around with this. I eventually disabled SELinux, which solved the NFS problem, but the NSLU2 still appeared to hang (though not really hang) in the same place. I then ran the MAKEDEV script that is located in the /dev directory:

sh MAKEDEV -m ~/usr/src/tooldir/bin/nbmknod all

which created all of the devices in the NFS server's client/root/dev directory. At this point, the NSLU2 booted up in single user mode. I then partitioned, formatted, and USB disk, which I haven't tried yet, but will as soon as all of the files are copied over to it (kind of slow).

It seems to me that something still wasn't right, since my reading indicated that /dev should have been created automatically during boot up.

rtos had a different, and interesting, suggestion, which is the subject of the next email.

Claudio Leite wrote:
* Donald T Hayford (don%donhayford.com@localhost) wrote:
Problems described below are definitely NFS problems. I checked /var/log/messages on the TFTP/NFS server (Fedora 7) and saw the following:

I had similar issues using a Debian NFS server, but after installing
NetBSD on that same machine and serving NFS root from there I got a
working system, from which I then loaded a USB disk.

I'd like to know -why- it's doing that, but in the meantime this is a
workaround you can try.


Home | Main Index | Thread Index | Old Index