Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xen 4 DOM0 with -current i386/amd64 rejects kernel?

On 2/10/12 12:43 PM, John D. Baker wrote:
I'm finally able to put some time toward learning to use Xen again
and want to go ahead with Xen 4.1.2 as available in pkgsrc-2011Q4.
The boot loader loads the netbsd-XEN3_DOM0 kernel (amd64)
(netbsd-XEN3PAE_DOM0 on i386) and multiboots the "xen.gz" kernel, but
xen claims the DOM0 kernel is not an ELF binary.

I've seen this before, but I can't recall exactly what I did to resolve it. Have you updated the bootloader? I'm definitely running xen 4.1.2 dom0s with recent NetBSD dom0 kernels (5.99.59, 5.99.64). I know there have been issues with the bootloader and various things which have been fixed in -current over the last year or so.

Booting a regular kernel loads all modules from the appropriate path.
My machine's "/var" is on a different partition from the boot device
so I relocate the entropy file to "/stand/db" in "/boot.cfg" and in

I'm not 100% sure this will work; netbsd xen kernels can't currently load modules, and I'm not sure whether that will apply to rndseed as well.

I've mostly seen references to NetBSD as DOMU under XEN 4.  Am I missing
something in booting XEN 4 with NetBSD as DOM0?  Using a different DOM0
(i.e. a penguin-OS) is not really an option because of the disruption
it would cause.

I last tried with XEN3.3 and NetBSD 5.1_STABLE.  I could boot DOM0, but
never got around to succeeding with getting a DOMU running.  The DOM0
kernel lacked a number of important devices needed for my usual work,
so I had to put it aside.  I had to start using -current to get better
device and application support, but last I tried with XEN3.3 it would
crash and hang on boot with a -current netbsd-XEN3PAE_DOM0 kernel.

Now that I have time and access to resources to put towards learning
XEN, it seems I'm thwarted yet again.

Don't give up! I'm definitely doing what you're looking to do, though I don't use a PAE dom0 kernel, only amd64.


Home | Main Index | Thread Index | Old Index