Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Xen 4 DOM0 with -current i386/amd64 rejects kernel?

I'm finally able to put some time toward learning to use Xen again
and want to go ahead with Xen 4.1.2 as available in pkgsrc-2011Q4.
The boot loader loads the netbsd-XEN3_DOM0 kernel (amd64)
(netbsd-XEN3PAE_DOM0 on i386) and multiboots the "xen.gz" kernel, but
xen claims the DOM0 kernel is not an ELF binary.

Boot transcript (i386 example, amd64 is similar):
* squash.bozonet.ntc - NetBSD-5.99.64/i386 *

Please select from one of the following options:
WARNING: couldn't open acpiverbose (//acpiverbose/acpiverbose.kmod)
WARNING: couldn't open pciverbose (//pciverbose/pciverbose.kmod)
WARNING: couldn't open scsiverbose (//scsiverbose/scsiverbose.kmod)
WARNING: couldn't open usbverbose (//usbverbose/usbverbose.kmod)
WARNING: couldn't open miiverbose (//miiverbose/miiverbose.kmod)
WARNING: couldn't open ffs (//ffs/ffs.kmod)
Loading /stand/db/entropy-file Loading /netbsd-XEN WARNING: 6 modules failed to load
 __  __            _  _    _   ____
 \ \/ /___ _ __   | || |  / | |___ \
  \  // _ \ '_ \  | || |_ | |   __) |
  /  \  __/ | | | |__   _|| |_ / __/
 /_/\_\___|_| |_|    |_|(_)_(_)_____|

(XEN) Xen version 4.1.2 (sysop@) (gcc version 4.5.3 (NetBSD nb2 20110806) ) Wed Feb 8 19:00:20 CST 2012
(XEN) Latest ChangeSet: unavailable
(XEN) Bootloader: unknown
(XEN) Command line: dom0_mem=512M console=com1 com1=9600,8n1
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: none; EDID transfer time: 0 seconds
(XEN)  EDID info not retrieved because no DDC retrieval method detected
(XEN) Disc information:
(XEN)  Found 1 MBR signatures
(XEN)  Found 1 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009fc00 (usable)
(XEN)  000000000009fc00 - 00000000000a0000 (reserved)
(XEN)  0000000000100000 - 000000007ffe2800 (usable)
(XEN)  000000007ffe2800 - 0000000080000000 (reserved)
(XEN)  00000000feda0000 - 00000000fee00000 (reserved)
(XEN)  00000000ffb80000 - 0000000100000000 (reserved)
(XEN) System RAM: 2047MB (2096644kB)
(XEN) ACPI: RSDP 000FDE50, 0014 (r0 DELL  )
(XEN) ACPI: RSDT 000FDE64, 0028 (r1 DELL    CPi R   27D20811 ASL        61)
(XEN) ACPI: FACP 000FDE90, 0074 (r1 DELL    CPi R   27D20811 ASL        61)
(XEN) ACPI: DSDT FFFE4000, 3134 (r1 INT430 SYSFexxx     1001 MSFT  100000E)
(XEN) ACPI: FACS 7FFFF800, 0040
(XEN) Xen heap: 9MB (9788kB)
(XEN) Domain heap initialised
(XEN) Table is not found!
(XEN) Local APIC disabled by BIOS -- you can enable it with "lapic"
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Detected 1994.144 MHz processor.
(XEN) I/O virtualisation disabled
(XEN) Platform timer is 3.579MHz ACPI PM Timer
(XEN) Allocated console ring of 16 KiB.
(XEN) Brought up 1 CPUs
(XEN) xenoprof: Initialization failed. No APIC
(XEN) elf_init: not an ELF binary
(XEN) (XEN) ****************************************
(XEN) Panic on CPU 0:
(XEN) Could not set up DOM0 guest OS
(XEN) ****************************************
(XEN) (XEN) Reboot in five seconds...

The "/boot.cfg" file for the host example above (using last "menu"
banner=* squash.bozonet.ntc - NetBSD-5.99.64/i386 *
banner=Please select from one of the following options:
menu=Boot normally:rndseed /stand/db/entropy-file;boot netbsd
menu=Boot single user:rndseed /stand/db/entropy-file;boot netbsd -s
menu=Disable ACPI:rndseed /stand/db/entropy-file;boot netbsd -2
menu=Disable ACPI and SMP:rndseed /stand/db/entropy-file;boot netbsd -12
menu=Drop to boot prompt:prompt
menu=Boot Xen w/512MB dom0:rndseed /stand/db/entropy-file;load /netbsd-XEN 
console=pc;multiboot /xen.gz dom0_mem=512M
menu=Boot Xen w/512MB dom0 single-user:rndseed /stand/db/entropy-file;load 
/netbsd-XEN console=pc -s;multiboot /xen.gz dom0_mem=512M
menu=Boot Xen w/512MB dom0 single-user (serial):consdev com0;rndseed 
/stand/db/entropy-file;load /netbsd-XEN console=com0 -s;multiboot /xen.gz 
dom0_mem=512M console=com1 com1=9600,8n1
# Always load verbosity modules

Booting a regular kernel loads all modules from the appropriate path.
My machine's "/var" is on a different partition from the boot device
so I relocate the entropy file to "/stand/db" in "/boot.cfg" and in

I've mostly seen references to NetBSD as DOMU under XEN 4.  Am I missing
something in booting XEN 4 with NetBSD as DOM0?  Using a different DOM0
(i.e. a penguin-OS) is not really an option because of the disruption
it would cause.

I last tried with XEN3.3 and NetBSD 5.1_STABLE.  I could boot DOM0, but
never got around to succeeding with getting a DOMU running.  The DOM0
kernel lacked a number of important devices needed for my usual work,
so I had to put it aside.  I had to start using -current to get better
device and application support, but last I tried with XEN3.3 it would
crash and hang on boot with a -current netbsd-XEN3PAE_DOM0 kernel.

Now that I have time and access to resources to put towards learning
XEN, it seems I'm thwarted yet again.

Thanks for your suggestions.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index