Port-amd64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cdrecord on amd64 ?

   is anyone using cdrecord on amd64 ? I'm having troubles getting it
   working with a DVD writer on amd64. The drive reports error like "illegal
   request", or sometimes it looks like the command doesn't even make it
   to the drive. While building cdrecord I've seen some warnings about
   "cast from pointer to integer of different size", so I suspect some
   LP64 issues here.

   Manuel Bouyer, LIP6, Universite Paris VI.           
        NetBSD: 26 ans d'experience feront toujours la difference

I use it all of the time.

I had a Sony/Optiarc DVD+-R/RW DL drive and now a LiteOn DVD+-R/RW DL with
Lightscribe.  Both are ATAPI drives over a IDE channel.

The LiteOn is pretty new and I have not found all of the quirks.  On the
Sony, I had two odd things:

1) Burnfree had to be turned on.  If it wasn't there would be errors from
   the drive.  I seem to remember that this was true of both CDs and DVD,
   when I was still using dvdrecord [which I no longer use].  Use
   driveropts=burnfree on the command line.

2) Using growisofs to burn DVD+R DL disks, I could not specify a speed,
   nor could I tell it to make the disk "dvdcompat".  If either of those
   were used, the burn would error before it really got going.

Unless I was burning a DVD+-RW, which I always burn as fast as I can, I
always burn DVD+-R and CDs as slow as the software would let me, so there
might be issues with faster burns... don't know...

Brad Spencer - brad%anduin.eldar.org@localhost - KC8VKS
http://anduin.eldar.org  - & -  http://anduin.ipv6.eldar.org [IPv6 only]

Home | Main Index | Thread Index | Old Index