pkgsrc-WIP-discuss archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bl3 (RE: new GNUstep package ... help?)

OK...I figured I would convert my BL3-ify the DEPENDS in my Makefile.  For
example, I changed

DEPENDS+=       gnustep-back>=1.13.2


BUILDLINK_API_DEPENDS.gnustep-back+=    gnustep-back>=1.13.2
.include "../../x11/gnustep-back/"

and tried bmake.  (I currently have gnustep-back 1.14.0 installed.  Patch
for that update already mailed to rh@.)  After verifying a few other
dependencies, I get the notice

=> Full dependency gnustep-back>=1.13.2: NOT found
=> Verifying reinstall for ../../x11/gnustep-back

So what's up?  This is part of why BL3 confuses me.  The old DEPENDS is very
simple and intuitive.  It seemed to work.  Now I try the "new and improved"
method, and I get absurd conflicts.  Please help me understand.


Tim Larson        AMT2 Unix Systems Administrator
    InterCall, a division of West Corporation

               Eschew obfuscation!

Attachment: smime.p7s
Description: S/MIME cryptographic signature

This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
pkgsrc-wip-discuss mailing list

Home | Main Index | Thread Index | Old Index