pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: redis problem: can't load module redisbloom.so



I have got no clue whatsoever what that redisbloom is!
This just pops up on my end, in multiple occasions that I have now tested.
Even when I deploy a brand new lipkg zone with pkgsrc 'trunk' bootstrapped and install the redis package from there, and try to enable/start the redis service, it now errors this message.

I really hope someone on the list (Jonathan Perkin maybe?) can shed some light.


On 21-09-2026 14:12, Greg Troxel wrote:
Andries Annema <an3s.annema%gmail.com@localhost> writes:

The log file at /var/log/redis/redis.log states this:

[...]
24388:M 20 Sep 2026 15:34:42.497 # Module
./modules/redisbloom/redisbloom.so failed to load: ld.so.1:
redis-server: fatal: ./modules/redisbloom/redisbloom.so: open failed:
No such file or directory
24388:M 20 Sep 2026 15:34:42.497 # Can't load module from
./modules/redisbloom/redisbloom.so: server aborting
[...]
What is redisbloom?  It does not appear in 8.8 or 8.10 packages that I
hvae built on NetBSD 10 amd64.  It does not appear in /usr/pkg on my
2026Q2 nextcloud instance.


Home | Main Index | Thread Index | Old Index