So I just updated an OmniOSce box from r151054 LTS via r56 to
"latest stable" r58 now.
On the host itself and some lipkg zones I'm using pkgsrc
applications and the Nextcloud zone is now giving troubles:
I made sure the trunk repo was bootstrapped and did a "pkgsrc update && pkgsrc upgrade" to update all packages. As it updated to this couple (among others, but here lies the problem) ...
php83
php83-redis-6.3.0
redis-8.10.0
... the redis service fails to start.
The log file at /var/log/redis/redis.log states this:
[...]
24388:M 20 Sep 2026 15:34:42.497 # Module
./modules/redisbloom/redisbloom.so failed to load: ld.so.1:
redis-server: fatal: ./modules/redisbloom/redisbloom.so: open
failed: No such file or directory
24388:M 20 Sep 2026 15:34:42.497 # Can't load module from
./modules/redisbloom/redisbloom.so: server aborting
[...]
When I roll back the zone (ZFS FTW!) it runs fine with this couple:
pkgsrc 2025Q4
php 8.3
php 8.3 redis 6.3.0
redis 8.4.0
I have another (production) OmniOSce box running r151056, also with a Nextcloud lipkg zone, which is currently at:
pkgsrc trunk
php 8.3
php 8.3 redis 6.3.0
redis 8.8.0
which also gives no such redisbloom.so failure.
I am very reluctant of updating this to 8.10.0 now...
When I try to reproduce the issue on an OmniOSce r151058 testbox, with:
pkgsrc trunk
php 8.3
php 8.3 redis 6.3.0
redis 8.8.0
updating it to 8.10.0 and manually restarting the redis service afterwards, give the same failure.
Did something specific break in between redis 8.8.0 and 8.10.0?
What causes this and how can it be resolved?
Any pointers much appreciated.
Thank you and cheers,