pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

textproc/link-grammar build (ant) can't find java?

I last built "textproc/link-grammar" on i386-8.99.19, probably during
the pkgsrc-2018Q1 time frame or some time before the freeze for pkgsrc-2018Q2.
Also on amd64-8.0_BETA on 11 December 2017 during the run-up to the
freeze for pkgsrc-2017Q4.

Now, with i386-8.99.22 (pkgsrc-2018Q2) and amd64-8.0_STABLE (pkgsrc-HEAD
as of 20180914), building textproc/link-grammar fails with:

Making all in java
Error: JAVA_HOME is not defined correctly.
  We cannot execute java
*** Error code 1

make[2]: stopped in /d0/build/pkgsrc/textproc/link-grammar/work/link-grammar-5.3.7/bindings/java
*** Error code 1

make[1]: stopped in /d0/build/pkgsrc/textproc/link-grammar/work/link-grammar-5.3.7/bindings
*** Error code 1

make: stopped in /d0/build/pkgsrc/textproc/link-grammar/work/link-grammar-5.3.7
*** Error code 1

make[1]: stopped in /x/pkgsrc/textproc/link-grammar
*** Error code 1

make: stopped in /x/pkgsrc/textproc/link-grammar

I do not set JAVA_HOME anywhere and 'make show-var VARNAME=JAVA_HOME'
indicates is is not set on any of the above platforms.

Looking at the '/usr/pkg/bin/ant' wrapper script, it appears JAVA_HOME
will not be set unless the user has a "$HOME/.ant/ant.conf" file.  I
(or rather the user account I use for building packages) have never had
this on any host and the use of 'ant' as a tool for packages has worked
on these platforms in the past.

I tried setting up the "$HOME/.ant/ant.conf" file (empty, of course),
but it made no difference.

On the amd64-8.0_STABLE system, openjdk8-1.8.172nb1 is installed,
as is apache-ant-1.10.5.

The rebuild was originally being done via 'pkg_rolling-replace'.
Subsequent manual attempts received the same error.

Anyone else seeing anything like this?

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index