pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pbulk on Solaris 10

so instead of running the script, i tried to create the perl5 packages (make clean clean-depends ; make package) and see if the interpreter was still written whitout a path and still causing an issue. Guess what ? It worked without any issue and the "" files still have "#!perl" as an interpreter.
I even compiled the perl5 package on NetBSD (sparc) to compare. Here again the interpreter is  "#!perl" in the "" files.

[root@Solaris10_host ~]$ head -1 /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/
[root@Solaris10_host ~]$ head -1 /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/
[root@Solaris10_host ~]$ head -1 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/
[root@Solaris10_host ~]$ head -1 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/  

[root@NetBSD8_host ~]$ head -1 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/ 
[root@NetBSD8_host ~]$ head -1 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/

As suggested by Rolang, I also verified permissions on files. All ( which mean Solaris with pbulk script, Solaris pkgsrc and NetBSD pkgsrc ) are all 444 :

[root@Solaris10_host ~]$ ls -lh /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/
-r--r--r--   1 root     root        1.2K Sep  9 14:40 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/
[root@Solaris10_host ~]$ ls -lh /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/  
-r--r--r--   1 root     root         991 Sep  9 14:40 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/
[root@Solaris10_host ~]$ ls -lh /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/
-r--r--r--   1 root     root        1.2K Sep  8 10:12 /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/
[root@Solaris10_host ~]$ ls -lh /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/
-r--r--r--   1 root     root        1.2K Sep  8 10:12 /tmp/obj-pbulk/lang/perl5/work/.destdir/usr/pbulk/lib/perl5/5.26.0/Math/BigFloat/

[root@NetBSD8_host ~]$ ls -lh /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/
-r--r--r--  1 root  wheel  1.2K Sep 11 18:07 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigFloat/
[root@NetBSD8_host ~]$ ls -lh /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/
-r--r--r--  1 root  wheel  991B Sep 11 18:07 /usr/pkgsrc/lang/perl5/work/.destdir/usr/pkg/lib/perl5/5.26.0/Math/BigInt/

With this in mind, I don't think the nor the interpreter neither the permission is the root of the issue. But well I might be wrong.. I'm open to any suggestion.

On Fri, Sep 7, 2018 at 1:45 PM Roland Illig <> wrote:
Am 06.09.2018 um 14:38 schrieb Julien Savard:
> ERROR: [] The interpreter "perl" of
> ".../Math/BigFloat/" does not exist.
The documentation in mk/check/ says:

# This file checks that after installation, all files of the package
# that start with a "#!" line will find their interpreter. Files that
# have a "#!" line with a non-existent interpreter will generate an
# error message if they are executable, and a warning message otherwise.

Since you got an error message (and not a warning message), this means
that the Perl modules are marked as executable, which is unnecessary.
They should be installed with mode 0644 or even 0444. You should find
out why they are executable on your system.

If nothing else helps, have a look at CHECK_PERMS_AUTOFIX, which is
defined in mk/check/


Home | Main Index | Thread Index | Old Index