pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Compiler with PCH support? gcc-aux and gcc5-aux fail to build

I tried to update lang/gcc-aux among other packages with pkg_chk and failed with a strange message.

End of log is

checking how to hardcode library paths into programs... immediate
checking for exception model to use... call frame
checking for compiler with PCH support... 

and there it hung.  All I could do, after several hours, was get out with Ctrl-C.

uname -a shows

NetBSD amelia2 8.99.1 NetBSD 8.99.1 (NetBSD-current i386 with DRMKMS.nb899-20170614) #0: Wed Jun 14 12:28:01 GMT 2017  root@amelia:/BETA1/usr/obj.i386/BETA1/usr/src/sys/arch/i386/compile/BOTHF7-noathn i386

Compiler was presumably GCC 5.4.0 from base system.

What is PCH?  I looked on Wikipedia and found precompiled headers.  Is this something lacking in NetBSD's base gcc?

I also tried lang/gcc6-aux but failed for reasons made apparent by subsequently reading the Makefile.


Home | Main Index | Thread Index | Old Index