pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Modular Xorg in pkgsrc, was Mouse pointer in pkgsrc xorg half-crippled

On 29/08/2013 02:16, Martin S. Weber wrote:
> Simple story really. [...]
> During trip, realize X won't work (no screens found).

Pierre Pronchery responded:

> indeed, modular Xorg from pkgsrc-2013Q2 is broken on netbsd-6. NetBSD's
> Xorg is apparently at 1.10.6 (1.10.3 for netbsd-6) and doesn't require
> KMS, while modular Xorg in pkgsrc-2013Q2 is at 1.12.4 and does require
> KMS - which we do not have yet.

> I am wondering what our options could be to get back to a working state
> with modular Xorg on netbsd-6. I guess Taylor wouldn't mind some help
> implementing KMS. Any other ideas?

> Cheers,
> khorben

My last update of modular Xorg on NetBSD was about last June 20, only on NetBSD 
6.1 i386, and I posted the following problem on June 27.

That stopped me from attempting to update NetBSD or packages on netbsd-6 amd64 
or netbsd-HEAD i386 or amd64.

I can say FreeBSD is also having problems with KMS on xorg-server 1.12.4, 
including not being able to return to text console after starting X.

Would I have a better chance with HEAD?  I don't really want to go further with 

Here is what happened (sent last June 27):

I recently upgraded modular xorg on NetBSD 6.1, subsequently hoping in vain to 
get print/hplip working on my HP LaserJet M1212nf MFP.

But I noticed that the mouse pointer would move right-to-left and back but not 
up or down.

Sometimes the mouse pointer wouldn't move at all.

I tried Protocol = "wsmouse", "auto" and "USB".

I tried Driver = "vga", "vesa", and "r128", haven't tried "intel" yet.

This is a USB-stick installation that can run on either of two computers, hence 
the "r128" and "intel".

Has anybody else experienced this mouse misbehavior/semi-crippling?

In the past, sometimes the mouse pointer would move, sometimes not, but never 
just horizontally.

On the VT console, most of the time wsmouse didn't work.

I have built and installed NetBSD i386 and amd64 on USB sticks for netbsd-5, 
netbsd-6 and HEAD.


Home | Main Index | Thread Index | Old Index