[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: (pkglint) OVERRIDE_GEMSPEC is modified using "+=", its name should indicate plural.
On Sat, May 11, 2013 at 11:35:34AM +0900, Makoto Fujiwara wrote:
> I have pkglint warning, for example at net/ruby-twitter
> WARN: Makefile:12: As OVERRIDE_GEMSPEC is modified using "+=", its name
> should indicate plural.
> Which do you like ?
> (1) Ignore this message.
> (2) Rename OVERRIDE_GEMSPEC to OVERRIDE_GEMSPECS.
> .. I consulted with dictionary getting plural of specification
> is specifications ..
> (3) Change += to = (But not to follow help as described:)
> make help topic=OVERRIDE_GEMSPEC
> (4) Fix pkglint (but how ?)
(1) would be my preferred choice.
Personally, I really don't see the motivation for changing 586
packages from one definition to another, of deprecating that
definition over N pkgsrc releases, and getting anyone who has 3rd
party packages like in wip or private or work ones, just because
someone gets uptight over a missing 'S' in a name that is dubious at
But I am obviously getting old.
To ask other questions about the pkglint warning:
1. Why should a name indicate plural just because a "+=" is used?
2. "SPEC" is an abbreviation. Is correct English usage to use an
'S' in abbreviations where plural. cf English "maths" vs US English
3. Even if I were to believe unquestioningly in the obvious benefits
of this, why do it now?
4. What if the plural of a definition does not have a traditional -s
suffix? Can we link pkglint to spell/ispell/aspell without incurring
the licensing gods wrath?
Main Index |
Thread Index |