pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: icu upgrade breaks openoffice

> >I guess the in textproc/icu/
> >needed to be increased.

> Yes, and missing recursive bump...anyone taking care about it?

> --
> OBATA Akio /

I responded, with Jeremy C. Reed's response prefixed by > :

Maybe you need to rebuild openoffice and all other ports that depend on icu?

> Yes, that is what is meant above.

This advice comes from the FreeBSD ports UPDATING file, maybe it applies
equally with NetBSD pkgsrc?

> Yes. But instead of documenting a manual step, we want this automatic
> for the builders and end-users.

That would update the library version numbers.

> I will handle it.

How might you implement such an automated step, updating all packages that
depend on icu?  What would the end-user do?  pkg_rolling-replace?  Nothing
quite like FreeBSD ports' portmaster and portupgrade. 


Home | Main Index | Thread Index | Old Index