pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [HEADS UP] cairo downgraded

> On Mon, Oct 08, 2012 at 11:57:31PM +0200, Thomas Klausner wrote:
>  > I've updated cairo to 1.12.4 yesterday, but it causes problems on OS X
>  > Lion and NetBSD (too old Xserver, I guess), so I had to revert it.

> FTR, it also doesn't build on netbsd-5; the SHM stuff needs to be
> disabled.

> This is not because netbsd-5's native X doesn't have the SHM
> extension, which is one of the older X extensions around; it's because
> x11-links is broken.

> --
> David A. Holland

Use modular (pkgsrc) Xorg instead of native?  That would get around the
problem of x11-links, which was a never-ending source of problems building
packages from pkgsrc.  Then maybe current version of graphics/cairo would
work right?


Home | Main Index | Thread Index | Old Index