pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: in pkgsrc/www/apache24

On 24/08/2012 8:03 PM, Ryo ONODERA wrote:
From: David Brownlee <>, Date: Thu, 23 Aug 2012 
08:56:15 +0100

On 23 August 2012 05:06, Ryo ONODERA <> wrote:

I have a plan to update www/apache24 to 2.4.3.
With this update, I will meke --enable-mpms-shared='event prefork worker'
default. Then www/apache24 lacks module at all,
of course exists.

Any objection?

I will update www/apache24 this weekend.
What is the failure mode for someone with an existing mod_cgi using
system - is it easy to determine that you need to switch to cgid?
I am not user of module.
But according to , and has same function.
Perhaps someone who had used can modify LoadModule line only.

(but in general I'm in favour :)

PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB  FD1B F404 27FA C7D1 15F3

I've used both mod_cgi and mod_cgid under apache 2.2 with no issues. Didn't even have to change any other configuration lines other than the change to use the different LoadModule as long as your happy with the the default location of the socket used by mod_cgid.

Chrooting apache my require further config changes with respect to the socket directory.

Is there going to be a message about this change when installing apache 2.4 package?

Ian McWilliam

Home | Main Index | Thread Index | Old Index