pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: py27-libxml2.2.7.8nb1 no Parser found

On Wed, 06 Jun 2012 18:01:16 +0900, Maurizio Caloro <> 

# python2.7 -c "import xml.parsers.expat"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/pkg/lib/python2.7/xml/parsers/", line 4, in <module>
    from pyexpat import *
ImportError: /usr/pkg/lib/python2.7/lib-dynload/ Undefined PLT symbol 
"XML_SetHashSalt" (symnum = 78)

But why "undefined PLT symol", and "expat not supported?"
Expat are compiled without error from pkgsrc.

How did you install whole packages?
Do you have expat package?

XML_SetHashSalt is introduced by expat-2.1.0, but expat in NetBSD-5 should be 

OBATA Akio /

Home | Main Index | Thread Index | Old Index