pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg_db corrupt : What is the way out?

I have been getting following kind of error for many packages:

pkg_add: Conflicting PLIST with <old version>: <some file>

Even pkg_delete of old version, prior to pkg_add/install is not able to
avoid this error.

pkg_add -f is a workaround for now, which shows above error though
installs the package, though I don't think it's the right solution.

This probably shows a corrupt pkg_db (or is there any other possibility I
should check?).

Are there any ways to repair / rebuild the pkg db?


Home | Main Index | Thread Index | Old Index