pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: update lang/gawk

On Sun, Mar 04, 2012 at 03:41:36PM +0400, Aleksej Saushev wrote:
> > gawk 4.0 has quite some new features. I do not know whether they have
> > stated anything about backward compatibility. Also, a user would need to
> > be conscious about portability of his/her work on older gawk versions.
> >
> > I think, it's a mini-version of problem faced with python versions.
> >
> > How about new package gawk4?
> He meant that PKGREVISION should be just removed rather than set to some
> random value. :)

I wasn't worried about PKGREVISION. Worried about using gawk4 as a
replacement of gawk3.

I have been into situations where one code taking gawk capabilities for
granted and then the code doesn't work on systems with classical awk.

Same can happen between gawk4 and 3. Same we see happening between python
versions. Just that we may not hear so much fuss about it with awk, due to
relatively less usage (compared to python I mean).

It's better if the programmer makes an explicit choice of using a higher


Home | Main Index | Thread Index | Old Index