pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Anyone have firefox working on i386?

"David H. Gutteridge" <> writes:

> I have a similar video card and am not experiencing any problems
> like this.  I haven't updated the machine in question in a while (it
> hasn't been connected to the internet in months), but it was running
> Firefox 7 without trouble.  I've appended my xorg.conf file below in
> case it's of use.  (Oh, and I'm running the netbsd-5 branch as well.)

Thank you.  The main difference I see is that you specify dri2.  When
I try that it simply doesn't get loaded, complaining:
  (WW) intel(0): DRI2 requires UXA

but if I try to force "AccelMethod" "UXA", X puts garbage on the
screen and hangs on start-up.

I tried just using your xorg.conf as is; firefox still cannot start.

I can run firefox4 on this machine by booting from a MythBuntu
"live CD".  The resulting Xorg.0.log suggests that MythBuntu
has a much more recent X server:

   X.Org X Server 1.10.1
   Release Date: 2011-04-15

compared to my NetBSD 5 O/S:

   X.Org X Server 1.6.3
   Release Date: 2009-7-7

I do keep my machine updated; I can only surmise that NetNSD 5 stable
uses an oldish X server version.  David, can you tell me what version
is reported in your Xorg.0.log ?  Perhaps you'd be willing to send me
a copy of your Xorg.0.log so I could compare it to mine?

Ms. Anne Bennett, as a private citizen:
Also reachable more officially at work:

Home | Main Index | Thread Index | Old Index