pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: RFC - p5-* dependencies and Perl core modules

> So for spamassasin, dependency pattern should be changed as following:
> {perl>=5.9.3,p5-Archive-Tar>=1.23}:../../archivers/p5-Archive-Tar

Woo. That's alot work :) This will make it possible to use an older
version of Perl and pkgsrc will pull the p5-Archive-Tar package.
Clever! But alot of work. Is that really needed?

Why don't we just skip backwards compatibility and generally require
the same Perl version as the pkgsrc tree. This would break the
possibility to update certain packages by using a newer pkgsrc tree
than the one you've used to build your current  Perl version on.

In order to get things going again I really would suggest that radical
change. Let's announce it, let's post it on the boards - "Guys we are
breaking backwards compatibility to pkgsrc versions older than ...<to
be determined>."
We shouldn't rely on Perl 5.14 - maybe Perl 5.12 is fine. pkgsrc
2011Q2 should be sufficient.

Home | Main Index | Thread Index | Old Index