pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Up-to-date browser?

On Sun, Jan 08, 2012 at 02:26:17PM +0100, 1126 wrote:
> I'm considering switching from Linux to NetBSD and one of the steps
> preceding my installation is to check wether all the software I need
> is available. Hence, I was browsing through the available packages
> and couldn't find Chromium and Firefox is not up-to-date. That seems
> awkward, so I'm confused. Are there no up-to-date-ports for the
> open-source browsers?

> Mayuresh responded:

> I am sailing in the same boat. I keep both systems handy as some things
> still don't work on NetBSD.

> For chromium see one of the recent discussions:

> IMO firefox is not so _outdated_ on NetBSD. However I have not been able
> to get flash and java plugins work.

> Haven't tried opera on NetBSD. Perhaps that might work.

> Besides browser I face problems with sharing my Linux and NetBSD file
> systems. Unfortunately the stable 5.1 version does not have support for
> inode size > 256. So can't mount my Linux home directory on NetBSD. Have
> to sync rc files etc manually all the time.

> Other things I failed to get work on NetBSD - quite frustratingly so are:

> - Printer support
> - Sound card support

> Eagerly waiting for NetBSD 6 to solve some of these issues, though not
> sure about A. which of these will get resolved B. time line for 6.0

> Mayuresh.

I am behind on pkgsrc and pkgsrc-wip.  Only browsers I tried on NetBSD are Lynx 
(2.8.7nb2) and Seamonkey 2.0.11nb1 .

That was on the old computer, no intention to upgrade due to shortage of disk 
space and only 256 MB RAM.

I couldn't even get far enough with NetBSD on the new computer to build or 
install any packages.  Much better with FreeBSD.

There was an update to NetBSD 5.1_STABLE and HEAD improving ext2fs support that 
was previously limited to inode size <= 128.

That enabled me to mount and access my Linux Slackware installation, where file 
system is ext2fs with inode size 256.

So there is still no support for inode size > 256?

I couldn't get my printer, HP LaserJet n1212mf, to work under either FreeBSD, 
NetBSD or Linux Slackware 13.0 on the old computer.

That was using USB; I didn't try yet using Ethernet.

I also have that weird screenblanking bug in NetBSD beginning with 5.0.2, I 
hope NetBSD 6 will not have that bug, and that the screen will be visible even 
after going to X and subsequently exiting back to text mode.

I've written about that bug several times in 2010 and 2011.


Home | Main Index | Thread Index | Old Index