pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/audio/maplay

On 11/22/2011 6:00 PM, Joerg Sonnenberger wrote:
On Tue, Nov 22, 2011 at 05:48:07PM +0100, Thomas Klausner wrote:
When I remove the ifdef around your fix, it does build. Perhaps we
should make it dependent on the compiler version; or just change it
unconditionally and require a minimum gcc version -- I guess 4.4,
based on your comment above.
Just do it unconditionally without depending on the GCC version.
iostream.h has been deprecated for ages, at least since ISO C++.


I was wondering how this was building on NetBSD 5.99 as I was under the impression it was using gcc 4.5, and thus should have the same issues that DragonFly does.

I've got more iostream.h fixes on the horizon.
Do I have standing permission to unconditionally patch/inline-replace all iostream.h includes?


Home | Main Index | Thread Index | Old Index