pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: cvs operations broken after installing security/ssh2

On Sat, Nov 19, 2011 at 08:12:18AM -0600, Jeremy C. Reed wrote:
> I guess your path has your packages first.

I think that's how it should be. You wouldn't want to use base if you have
specifically built packages (and conversely you wouldn't build a package
if base has it and you are satisfied with it.)

> > However it works fine with following command, indicating it has to do with
> > installation of ssh2.
> > 
> > CVS_RSH=/usr/bin/ssh cvs stat
> > 
> > 
> > What's the right pkgsrc package to install if ssh2 is not compatible with
> > CVS Repo?
> pkgsrc/security/openssh

Yes. openssh works fine. Thanks.

> But why?  Why install pkgsrc package if the base (/usr/bin) already has 
> it? Or just remove the conflicting ssh2 package? Or fix your path to use 
> /usr/bin first?

/usr/bin somehow didn't have it on another machine I have which mirrors
/usr/pkg from first machine where I do builds. That apart. I think if
/usr/pkg is first in the path it should work. That sounds logical to me.

> I didn't realize that ssh2 was incompatible.

Seems so. Anyway as you suggested openssh works. So I'll use that.


Home | Main Index | Thread Index | Old Index