pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Advice sought: which X11 for NetBSD 5.* (going forward) ??

On Wed, Sep 07, 2011 at 05:38:34PM +0100, David Brownlee wrote:
> On 7 September 2011 15:35, Greg Troxel <> wrote:
> >
> > Robert Elz <kre%munnari.OZ.AU@localhost> writes:
> >
> >> I'm wondering, as there doesn't eem to be any immediate effort towatds
> >> fixing stuff with the x11_xcb problem (like x11/startup-notification)
> >> that compile fine with modular X-org, but fail on NetBSD 5 native X11.
> >> (It is kind of weird to have packages that build on NetBSD 4, where I
> >> am using modular Xorg, and fail on NetBSD 5)
> >
> > But, it seems that modular (pkgsrc) xorg libX11 now has support for
> > libxcb, whereas netbsd-5 xorg does not.  I'm guessing that's nontrivial
> > to fix, requiring pulling up a lot of xorg things to netbsd-5.
> Either pkgsrc needs to be able to build against native X11 for
> netbsd-5, or it needs to default to using modular for netbsd-5.
> If the X in netbsd-5 is too old then its too old, all the more reason
> to ensure its fixed in current ready for netbsd-6.

I'm not sure if this is because /usr/X11R7 X is too old or for another reason,
but I've had more failures building and running LibreOffice with it than with
the pkgsrc version.

Anyone wanting to run a desktop should use X11_TYPE=modular IMHO.

Francois Tigeot

Home | Main Index | Thread Index | Old Index