pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: devel/GConf fails to build on -current "#~| msgid"

On Wed, 27 Apr 2011 23:26:57 +0900, David Brownlee <> 

Just updated pkgsrc on my amd64 boxes and the netbsd-5 box builds
devel/GConf fine, but the 5.99.49 box (using identical config) fails
to build with

es.po:2725:4: parse error
es.po:2725: missing `msgstr' section

The offending line is the first of the block:

#~| msgid "Could not send message to gconf daemon: %s"
#~ msgid "Could not send message to GConf daemon: %s"
#~ msgstr "No se pudo enviar un mensaje al demonio de GConf: %s"

commenting out the block on that and three other .po files allows the
build to complete.

Both netbsd-5 and 5.99.49 boxes report a msgfmt of 0.14.4.

Has anyone else seen this - anything I'm missing?

I feel it should be handled in pkgsrc/mk/tools/msgfmt-msgctxt.awk,
so awk issue on 5.99.49?

OBATA Akio /

Home | Main Index | Thread Index | Old Index