pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkgsrc-2011Q1/x11/gtk2 doesn't build on Alpha


x11/gtk2 from pkgsrc-2011Q1 doesn't build on NetBSD-5.1/Alpha:

/work/.buildlink/lib/ -lintl -pthread -Wl,-rpath
-Wl,/usr/pkg/lib -Wl,-rpath
undefined reference to `XCompositeReleaseOverlayWindow'
undefined reference to `XCompositeGetOverlayWindow'
gmake[4]: *** [gtk-query-immodules-2.0] Error 1 gmake[4]: Leaving
directory `/usr/src/pkgsrc-2011Q1/x11/gtk2/work/gtk+-2.24.3/gtk'

I am clueless in the X11 departement, so I am at a loss.
May this problem be ralated to NetBSD/Alpha still using XFree instead
of XOrg? (There was a problem of this kind in cairo and renderproto
that I solved with the help of pkg/43969. But there seems to be no PR
for the gtk2 problem.)



Home | Main Index | Thread Index | Old Index