pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pfstat-2.3nb4 install issue (2011Q1)

On Fri 15 Apr 2011 at 01:14:34 PM +0900, OBATA Akio wrote:
>On Fri, 15 Apr 2011 12:17:31 +0900, George Georgalis 
><> wrote:
>>On Fri 15 Apr 2011 at 10:48:55 AM +0900, OBATA Akio wrote:
>>>On Fri, 15 Apr 2011 08:14:49 +0900, George Georgalis 
>>><> wrote:
>>>>/usr/bin/install -c -s -o root -g wheel -m 555 
>>>>install: /usr/pkgsrc/sysutils/pfstat/work/pfstat-2.3/pfstatd/pfstatd: stat: 
>>>>No such file or directory
>>>>*** Error code 1
>>>I feel this is not a install issue.
>>>Probably something happened at build phase.
>>tried again...
>>3027    export LOCALBASE=/usr/pkg-2011Q1
>>3028    export PKG_DBDIR=/usr/pkg-2011Q1/db
>>3029    make clean
>>3030    /usr/pkg-2011Q1/bin/bmake install
>>same error, not sure what else could cause a problem.
>In other words, try bmake build, and look at why ${WRKSRC}/pfstatd/pfstatd is 
>not built.

Oh, okay, there is an invocation to build it in the work log

[*] /usr/pkgsrc/sysutils/pfstat/work/.wrapper/bin/cc 
/usr/pkgsrc/sysutils/pfstat/work/.wrapper/bin/cc -O2 -I/usr/pkg-2011Q1/include 
-I/usr/include -I/usr/pkg-2011Q1/include/freetype2 -Wall 
-I/usr/pkg-2011Q1/include -I/usr/include -I/usr/pkg-2011Q1/include/freetype2 -c 

work/pfstat-2.3/pfstatd/pfstatd.c doesn't seem to generate the file or error

there is an object file half the size as my old binary

-r-xr-xr-x  1 root  wheel  8216 Feb 27 11:51:40 2011 
-rw-r--r--  1 root  wheel  4156 Apr 15 10:37:36 2011 pfstatd/pfstatd.o

with bmake clean typescript build I get...

cc -O2 -I/usr/pkg-2011Q1/include -I/usr/include 
-I/usr/pkg-2011Q1/include/freetype2 -Wall 
-I/usr/pkg-2011Q1/include -I/usr/include -I/usr/pkg-2011Q1/include/freetype2 -c 
pfstatd.c: In function 'main':^M
pfstatd.c:160: warning: pointer targets in passing argument 3 of 'accept' 
differ in signedness^M

There aren't any significant comments in pfstatd.c, aside from
debugging C (which I cannot) not sure where else to go, I don't see
any more logs.


Home | Main Index | Thread Index | Old Index