pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USE_LANGUAGES difficulties

On Fri, 7 Jan 2011, Aleksej Saushev wrote:

msettgast <> writes:

I am using NetBSD 5.1 AMD64.
I have some difficulties regarding compiling several different pkgsrces.
For example pkgsrc/net/openvpn version 2.1.3.
If I try to compile openvpn, make stops and I got a message, that I should
add c to USE_LANGUAGES in the package Makefile.

This warning is only to those who knows details, it isn't for regular user.

I received this message for different pkgsrces with c, c++ and fotran.
I tried to add this option to /etc/mk.conf and also to the
Makefile of every pkgsrc, but unfortunately without any result.

Setting USE_LANGUAGES in mk.conf isn't really good idea.
In fact this breaks quite early thus confirming that it isn't good idea.

Until now I was not able to find a solution for this problem,
maybe somebody can give me a hint/ help me?!

You should address the real problem rather than messing with compiler selection.


I just updatetd pkgsrc and now it works flawless.
ps. I explained the real problem, what a pity, that I just received such a answer...


Home | Main Index | Thread Index | Old Index