pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libssh2 - openssl issue

On Tue, Mar 16, 2010 at 02:36:07PM +0100, Victor Dorneanu wrote:
> Is there any reasons why the openssl libraries in /usr/lib should be used
> instead of those in /usr/pkg/lib ?

Because "pkgsrc" tries by default to use the OpenSSL in the system
if possible

> Is there any way to specify this one option(--with-openssl=/usr/pkg)
> without modifing the Makefile?

Yes, please put "PREFER_PKGSRC+= openssl" into "/etc/mk.conf".

        Kind regards

Matthias Scheler                        

Home | Main Index | Thread Index | Old Index