pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problem building lang/python25 on Darwin

   Date: Tue, 26 Jan 2010 17:52:52 +0000
   From: Matthias Scheler <>

   On Tue, Jan 26, 2010 at 12:47:26PM -0500, Taylor R Campbell wrote:
   > OK.  Personally, I have confirmed that the same changes (changing
   > `expat' to `pyexpat' in patch-am, and omitting from the
   > PLIST) work for lang/python25.

   I'm not argueing that it shouldn't be fixed. I'm just saying that
   I'm using the "python25" package and don't want to commit it untested.

Understood -- I wasn't suggesting that my personal tests should be
reason enough for committing the change.

   Please submit a PR about this so it doesn't get forgotten.


   > lang/python25 is still the default except on 64-bit Darwin; that's why
   > I was using it in the first place.

   You can change that by adding "PYTHON_VERSION_DEFAULT= 26" to

Right.  It's just good for the default default to work, for users
(such as me) who are only trying to install something that happens to
depend on Python.

Home | Main Index | Thread Index | Old Index