pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Does firefox 3.5 on netbsd-4/i386 work?

Tobias Nygren wrote:

> On Mon, 23 Nov 2009 18:58:28 +0100
> Bernd Ernesti <> wrote:
> > I also get a core dump with 3.5.x. Thats why I keep the latest 3.0.x version
> > which still works, but that is not with netbsd-4, it is a with a little bit
> > older 3.99.x.
> I've been doing some testing with netbsd-4 in qemu. There seems to be
> some conflict between native X11 and pkgsrc.
> The following workaround makes firefox start for me on netbsd-4:
> LD_PRELOAD=/usr/pkg/lib/ /usr/pkg/bin/firefox               
> Could you guys test if this solves your problems too?

Seems to work much better.  I can now finally read that popup box that
disappeared instantly!  It says

        An error occurred while loading or saving configuration
        information for xulrunner-bin. Some of your configuration
        settings may not work properly.

The "details" button shows this:

        Failed to contact configuration server; some possible causes
        are that you need to enable TCP/IP networking for ORBit,
        or you have stale NFS locks due to a system crash. See for information. (Details -
        1: Failed to get connection to session: Failed to connect to
        socket /tmp/dbus-wIsZW9e8XY: No such file or directory)

If I quit firefox before dismissing that box, I still get an
xulrunner-bin core dump but if I dismiss that box straight away it
appears to be happy so far.  The backtrace (same as one of the previous
at a glance) from the core is:

  #0  0xb994a22f in kill () from /usr/lib/
  #1  0xb99e6340 in abort () from /usr/lib/
  #2  0xb99a8c06 in __assert13 () from /usr/lib/
  #3  0xb9b20207 in _cairo_hash_table_destroy () from /usr/pkg/lib/
  #4  0xb9b30383 in _cairo_scaled_font_map_destroy () from 
  #5  0xb9b1c2b2 in _cairo_font_face_reset_static_data () from 
  #6  0xb9b1c063 in cairo_debug_reset_static_data () from 
  #7  0xba4a7703 in gtk_moz_embed_get_title () from 
  #8  0xba4b0979 in XRE_main () from /usr/pkg/lib/xulrunner/
  #9  0x0804a9e8 in _rtld_setup ()
  #10 0x08049d84 in ___start ()
  #11 0x08049ce7 in _start ()

When I run "pmap -p <pid> | grep fontconfig" on a running firefox, I get
the following output:

  B9D21000    124K read/exec         /usr/X11R6/lib/
  B9D40000     12K read/write        /usr/X11R6/lib/
  BBBBE000    168K read/exec         /usr/pkg/lib/
  BBBE8000      8K read/write        /usr/pkg/lib/

I suspect that's not going to help?  Do we want a way to try to stop the
pkgsrc fontconfig being used altogether?


Home | Main Index | Thread Index | Old Index