pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

How to require JRE 1.5 or 6?


How can I require Java (JRE) 1.5 or newer for a packages? I tried this

RCS file: /cvsroot/pkgsrc/www/jalbum/Makefile,v
retrieving revision 1.23
diff -u -r1.23 Makefile
--- Makefile    13 Sep 2009 17:28:03 -0000      1.23
+++ Makefile    13 Sep 2009 17:37:36 -0000
@@ -18,7 +18,7 @@

 VERSION=               8.4

-USE_JAVA=              run
+USE_JAVA2=             1.5
 PKG_JVMS_ACCEPTED=     sun-jdk15 sun-jdk6

 WRKSRC=                        ${WRKDIR}/Jalbum

but pkglint gives me now a warning

# pkglint -Wall
WARN: Makefile:22: "sun-jdk6" is not valid for PKG_JVMS_ACCEPTED. Use one of { blackdown-jdk13 jdk jdk14 kaffe sun-jdk13 sun-jdk14 sun-jdk15 } instead.
WARN: PLIST:2: Manual page missing for bin/jalbum.
0 errors and 2 warnings found.

If I remove PKG_JVMS_ACCEPTED, then my currently installed sun-jre6-6.0.16 is not recognized and pkgsrc wants to install openjdk7-bin-20090502 (in addition to sun-jre6-6.0.16).

What is the correct way to handle this?


Home | Main Index | Thread Index | Old Index