pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Python 2.3 support

On Thu, Aug 27, 2009 at 09:05:33PM +0900, OBATA Akio wrote:
> > If you copy the do-install part and the PLIST, that is good enough.
> Why need custom do-install target?
> Now, allow multiple python version, should PKGNAME contain PYPKGPREFIX like 
> as ap2-mod_python?

The upstream install rule would need patching for DESTDIR and the
post-install rules are nasty as best. There is no good reason for it to
use a dynamic PLIST. It would be nice if the PKGNAME is modified
accordingly, yes.


Home | Main Index | Thread Index | Old Index