pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Python 2.3 support

On Sat, 15 Aug 2009 04:23:42 +0900, Joerg Sonnenberger 
<> wrote:

> On Sat, Aug 01, 2009 at 01:55:05PM +0200, Tonnerre LOMBARD wrote:
>> On Fri, Jul 31, 2009 at 12:47:41PM -0400, Greg Troxel wrote:
>> > This is the only one that jumped out at me as maybe mattering.  2.3 is
>> > ancient, and anything not keeping up is obviously unmaintained.  I
>> > suppose anyone running apache 1.3 is really behind in updating, so I
>> > don't object, just thinking out loud.
>> There are many valid reasons to run Apache 1.3 even these days, one
>> of them being licensing.
> I am aware of that. The question remains if anyone is actually using
> mod_python with Apache 1.3.

I can't find why www/ap-python is limited to python-2.3.
I'm just guessing that it was "not for python-1.5", but 
then added up to 23 (it was highest python at that time) and removed obsolete 
python version.

I just tested with python25 as mentioned in "2.4 Testing" of "Mod_python 
it works fine.

If no objection, I'll remove the restriction (and update to 2.7.11).

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index