pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Mesa 7.4.2 and xserver

On Wed, May 20, 2009 at 01:51:02PM +0300, Hasso Tepper wrote:
> The fact that recent intel driver update to the 2.7 broke X for me at all 
> (at best I have segfault in xorg server, at worst video hardware hang) 
> motivated me to put together Xorg update to the versions I can use to 
> report problems to the upstream at least (no go with such old server and
> Mesa we have in the pkgsrc at the moment).

Thank you!

> So, here it is. It still needs some cleanup probably and is tested only on 
> DragonFly. It makes my X work again and with better EXA performance than 
> ever before. It also introduces some new problems/crashes, but at least 
> now there is a point to report these problems to the upstream.

I've tried a limited bulk build of the packages touched by these
patches on NetBSD-5.99.11/amd64. Everything built fine except for
checking for GL... configure: error: Package requirements (glproto >= 1.4.1 dri 
>= 7.1.0) were not met:

No package 'dri' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GL_CFLAGS
and GL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1



Home | Main Index | Thread Index | Old Index