pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: emulators/suse100_base on NetBSD-5/amd64 broken?

On May 1, 2009, at 11:42 AM, Thomas Klausner wrote:
On Fri, May 01, 2009 at 01:26:39AM +0200, Fredrik Pettai wrote:
I recently started to use amd64 on some new machines, and had problems  
with the emulators/suse100_base + suse100_compat packages. The reason  
for using these are for our NetBackup client software...
I has worked fine on i386 for years, but now, then using amd64 is  

# uname -a
NetBSD localhost.localdomain 5.0_RC4 NetBSD 5.0_RC4 (GENERIC) #0: Wed  
Apr 15 00:11:21 UTC 2009
src/sys/arch/amd64/compile/GENERIC amd64

# pkg_info | grep suse
suse_base-10.0nb5   Linux compatibility package
suse_compat-10.0nb3 Linux compatibility package with old shared  

# sysctl emul.linux.kern.osrelease
emul.linux.kern.osrelease: 2.4.18

# chroot /emul/linux /bin/bash
bash-3.00# ls
Segmentation fault (core dumped)
bash-3.00# exit

As a data point, this works for me on NetBSD-5.99.11/amd64.

I spoke with, who wrote the LINUX_COMPAT/amd64,
and he said that I should use emul.linux.kern.osrelease = 2.6.11 or  
later for Linux/amd64 libc to load.
(btw. I can't find that documented either...)

So I gave that a try as well...

# sysctl -w emul.linux.kern.osrelease=2.6.11
emul.linux.kern.osrelease: 2.4.18 -> 2.6.11

# chroot /emul/linux /bin/bash
[1]   Segmentation fault (core dumped) chroot /emul/linux /bin/bash

And that seemed to perform even worse...

Works for me as well.

I did some better searches in the PR database, and found this:

So, is reported, but not fixed in NetBSD 4.99 - 5.0 it seems.
(Since it seems to work in 5.99.x it would be nice if it could be backported to 5.x STABLE)


Home | Main Index | Thread Index | Old Index