pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: MacOS 10.4 can't build packages

-------- Original-Nachricht --------
> I've just tried using pkgsrc (-current)for the first time under MacOS. The
> bootstrap went smoothly. Installing my first package went equally well, 
> but I'm unable to build a binary package:
> => Registering installation for joe-3.5
> ===> Building binary package for joe-3.5
> => Creating binary package /Users/sborrill/pkgsrc/packages/All/joe-3.5.tgz
> *** Error code 138
> Stop.
> bmake: stopped in /Users/sborrill/pkgsrc/editors/joe
> *** Error code 1

Strange. I've just pulled a -current pkgsrc onto my MacOS 10.4 PPC,
bootstrapped and started building packages and already have a number
of successfully created binary packages in packages/All (including, but
not limited to gettext-lib, gmake, pax, perl, ...). I do have pretty
ancient developer tools installed:

Using built-in specs.
Target: powerpc-apple-darwin8
Configured with: /private/var/tmp/gcc/gcc-5367.obj~1/src/configure 
--disable-checking -enable-werror --prefix=/usr --mandir=/share/man 
--with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/lib 
--build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 
Thread model: posix
gcc version 4.0.1 (Apple Computer, Inc. build 5367)

Is there something odd in your PATH that might be interfering?

Did you bootstrap generate binary packages and put them into

> I tried to run pkg_create manually based on _PKG_ARGS_PACKAGE:
> pkg_create -l -U -B /usr/obj/editors/joe/work/.pkgdb/+BUILD_INFO \
> -b  /usr/obj/editors/joe/work/.pkgdb/+BUILD_VERSION \
> -c /usr/obj/editors/joe/work/.pkgdb/+COMMENT \
> -d /usr/obj/editors/joe/work/.pkgdb/+DESC \
> -f /usr/obj/editors/joe/work/.PLIST_deps \
> -S /usr/obj/editors/joe/work/.pkgdb/+SIZE_ALL \
> -s  /usr/obj/editors/joe/work/.pkgdb/+SIZE_PKG \
> -p /usr/pkg -L /usr/pkg -v /tmp/joe-3.5.tgz
> This gave:
> Creating package /tmp/pkg
> Using SrcDir value of /usr/pkg
> Bus error

Almost looks like your pkg_create binary is broken. Do other binaries fail
this way as well? I suspect there might be something wrong with the
toolchain you're using, maybe you should try again with a clean PATH.



Home | Main Index | Thread Index | Old Index