pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

MacOS 10.4 can't build packages

I've just tried using pkgsrc (-current)for the first time under MacOS. The bootstrap went smoothly. Installing my first package went equally well, but I'm unable to build a binary package:

=> Registering installation for joe-3.5
===> Building binary package for joe-3.5
=> Creating binary package /Users/sborrill/pkgsrc/packages/All/joe-3.5.tgz
*** Error code 138

bmake: stopped in /Users/sborrill/pkgsrc/editors/joe
*** Error code 1

I tried to run pkg_create manually based on _PKG_ARGS_PACKAGE:

pkg_create -l -U -B /usr/obj/editors/joe/work/.pkgdb/+BUILD_INFO \
-b  /usr/obj/editors/joe/work/.pkgdb/+BUILD_VERSION \
-c /usr/obj/editors/joe/work/.pkgdb/+COMMENT \
-d /usr/obj/editors/joe/work/.pkgdb/+DESC \
-f /usr/obj/editors/joe/work/.PLIST_deps \
-S /usr/obj/editors/joe/work/.pkgdb/+SIZE_ALL \
-s  /usr/obj/editors/joe/work/.pkgdb/+SIZE_PKG \
-p /usr/pkg -L /usr/pkg -v /tmp/joe-3.5.tgz

This gave:
Creating package /tmp/pkg
Using SrcDir value of /usr/pkg
Bus error

ANy clues?


Home | Main Index | Thread Index | Old Index