pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: zope and python24

Takahiro Kambe wrote:
        Zope 2.11 requires Python 2.4.5 (Python 2.4.4 is still
        acceptable).  Older Python versions are no longer supported.
        Python 2.5 is not supported at this time.

"Python 2.5 is not supported" phrase is enclosed with "strong" tag.

Thank you, but I probably didn't make it quite clear enough.

I know zope does not support python 2.5 ... pkgsrc now prefers python 2.5 over 2.4 however.

When python 2.5 is installed, python modules for pyhton 2.5 override 2.4 producing an error like so:

ERROR: [] A package matching ``py24-expat>=0'' should
ERROR:     be installed, but one cannot be found.  Perhaps there is a
ERROR:     stale work directory for ../../textproc/py-expat?

It's this scenario I'm wanting to deal with. How exactly do I install the py4 version when the py5 version exists?


Home | Main Index | Thread Index | Old Index