pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problem building www/neon on Linux (libtool related)

Hi list,

I'm using pkgsrc-2008Q3.tar.gz on SLED 10 (SUSE Desktop) at work.

www/neon fails with the following (sorry, I disabled line wrapping):

% ===> Building for neon-0.26.3nb2
% /bin/sh ..//libtool --quiet --mode=link gcc -no-undefined -L/usr/lib 
-Wl,-R/usr/lib -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -rpath /usr/pkg/lib 
-version-info 26:3:0 -export-symbols-regex '^ne_[^_]' -o 
ne_request.lo ne_session.lo              ne_basic.lo  ne_string.lo              
 ne_uri.lo ne_dates.lo ne_alloc.lo   ne_md5.lo ne_utils.lo     ne_socket.lo 
ne_auth.lo     ne_redirect.lo ne_compress.lo                    ne_i18n.lo  
ne_207.lo ne_xml.lo  ne_props.lo ne_locks.lo  ne_xmlreq.lo  ne_acl.lo 
ne_openssl.lo -lz -Wl,-R/usr/pkg/lib -L/usr/pkg/lib -lssl -lcrypto -ldl   
% /usr/pkg/bin/libtool: eval: line 4430: syntax error near unexpected token `|'
% /usr/pkg/bin/libtool: eval: line 4430: `nm  .libs/ne_request.o 
.libs/ne_session.o .libs/ne_basic.o .libs/ne_string.o .libs/ne_uri.o 
.libs/ne_dates.o .libs/ne_alloc.o .libs/ne_md5.o .libs/ne_utils.o 
.libs/ne_socket.o .libs/ne_auth.o .libs/ne_redirect.o .libs/ne_compress.o 
.libs/ne_i18n.o .libs/ne_207.o .libs/ne_xml.o .libs/ne_props.o .libs/ne_locks.o 
.libs/ne_xmlreq.o .libs/ne_acl.o .libs/ne_openssl.o  |  | /bin/sed 's/.* //' | 
sort | uniq > .libs/libneon.exp'

As you can see, there seems to be a missing command, bause there are two
consecutive pipes "|  |".  I've spent a little time trying to debug, but
libtool is really too big compared to the time I can afford.  I hope
some libtool master will be able to figure out the problem quickly.

Thank you!
Jeremie Le Hen
< jeremie at le-hen dot org >< ttz at chchile dot org >

Home | Main Index | Thread Index | Old Index