pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: configuring enchant

On Sun, 5 Oct 2008 18:37:29 -0400
"Steven M. Bellovin" <> wrote:

> I'm trying to get enchant working; I need it as a spell-checker for
> the newest version of claws-mail (which I'll commit to pkgsrc when
> ready). However, enchant itself doesn't seem to work -- if I just run
> it on a file, it tells me "Couldn't create a dictionary for en".  How
> do I configure enchant to use, say, aspell's dictionary?
It turns out there were three problems.  First, enchant was not compiled
with aspell support; for that, the answer was to change /etc/mk.conf.
Second, though enchant was (by default) configured to use ispell,
there's no dependency on ispell in the enchant Makefile.  This, I
think, is a bug.  Finally, all three spelling checkers used by enchant
-- aspell, ispell, and hunspell -- are useless without a dictionary;
none are installed by default, nor are any messages displayed.  Should
those three packages have a MESSAGE file warning of that?

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index