pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Wierd problem with make (on anything)


Starting a few days ago, anytime I make anything (make install, make clean, make update on any package) I get this error:

make: "/usr/pkgsrc/pkgtools/pkg_install/../../mk/patch/" line 31: Malformed conditional (!empty(LOCALPATCHES)) make: "/usr/pkgsrc/pkgtools/pkg_install/../../mk/patch/" line 33: if-less endif make: "/usr/pkgsrc/pkgtools/pkg_install/../../mk/patch/" line 33: Need an operator

This is the contents of the script lines 31-33

.if !empty(LOCALPATCHES)
  local_patches=  ${:!echo ${LOCALPATCHES}/${PKGPATH}/*!:N*/CVS:N*/\*}

After updating my package tree this morning via CVS I still get them same errors. Is this a known problem?


Frank DeChellis
Internet Access Worldwide
3 East Main Street    Welland, Ontario, Canada    L3B 3W4
905-714-1400     fax 905-732-0524

Home | Main Index | Thread Index | Old Index