pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Two build failures: openoffice2 & gnash


At Wed, 30 Apr 2008 13:41:57 +0200,
Vincent wrote:
> I've tried to build the openoffice2 package (I know this might be deemed 
> preposterous) and it fails in the libxmlsec module:
> checking for crypto library... configure: error: At least one crypto 
> library should exist for xmlsec1
> dmake: Error code 1, (...)

Please let me know your OS, its version and PKG_OPTIONS.openoffice2.

> As for gnash, there are several problems:
> * When selecting an alternative renderer (instead of agg), via 
> PKG_OPTIONS, agg won't get away, so I end up with both agg and opengl 
> selected, for example, and configure doesn't like that.

It seems that the renderer should be selected from one of agg, cairo
or opengl.  I've attached a patch.

> * Building with opengl instead of agg fails:
> render_handler_ogl.cpp:43:32: error: render_handler_ogl.h: No such file 
> or directory.

That file is missing from tarball.

It can be downloaded from the following URL.*checkout*/gnash/backend/render_handler_ogl.h?revision=1.10&root=gnash

BTW, gnash fails to play some videos in YouTube due to bug of

The following patch is required for sysutils/gnome-vfs.

best regards.
 Kouichirou Hiratsuka

Description: Binary data

Home | Main Index | Thread Index | Old Index