pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Using nspluginwrapper on amd64/4.99.55 fails


I just tried using nspluginwrapper to add flash support to a native
firefox on NetBSD-4.99.55/amd64.

The instructions in nspluginwrapper's description are:
        To install the Linux flash player into a native Firefox browser:
          - Also install multimedia/ns-flash and multimedia/libflashsupport
          - Run "nspluginwrapper -i 
          - Run Firefox

The second step produces an error:
# nspluginwrapper -i /usr/pkg/lib/netscape/plugins/
/usr/pkg/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading 
shared libraries: cannot open shared object file: No such 
file or directory
nspluginwrapper: no appropriate viewer found for 

However, npviewer seems to be fine:
# /usr/pkg/emul/linux32/usr/bin/ldd 
         (0xffffe330) => /opt/gnome/lib/ (0xfbcf0000) => /opt/gnome/lib/ (0xfbc6e000) => /opt/gnome/lib/ (0xfbc34000) => /lib/ (0xfbc30000) => /opt/gnome/lib/ (0xfbba8000) => /usr/X11R6/lib/ (0xfbaaf000) => /usr/X11R6/lib/ (0xfba5d000) => /lib/ (0xfba0a000) => /lib/ (0xfb9ff000) => /lib/ (0xfb8de000) => /opt/gnome/lib/ 
(0xfb8c8000) => /opt/gnome/lib/ 
(0xfb8c1000) => /opt/gnome/lib/ (0xfb888000) => /opt/gnome/lib/ (0xfb86f000) => /opt/gnome/lib/ (0xfb86c000) => /usr/lib/ (0xfb81f000) => /usr/lib/ (0xfb7b1000) => /usr/lib/ (0xfb781000) => /usr/X11R6/lib/ (0xfb778000) => /usr/X11R6/lib/ (0xfb76a000) => /usr/lib/ (0xfb72b000) => /lib/ (0xfb718000) => /usr/lib/ (0xfb6f4000) => /lib/ (0xfb6ce000) => /usr/X11R6/lib/ (0xfb6c9000) => /usr/X11R6/lib/ (0xfb6c1000) => /usr/X11R6/lib/ (0xfb6be000) => /usr/X11R6/lib/ (0xfb6b5000) => /usr/X11R6/lib/ (0xfb6b0000)
        /lib/ (0xfbfe8000) => /usr/X11R6/lib/ (0xfb6a6000) => /usr/X11R6/lib/ (0xfb68e000) => /opt/gnome/lib/ (0xfb669000) => /usr/lib/ (0xfb649000)

Any ideas what's going wrong here and how to fix it?


Home | Main Index | Thread Index | Old Index