pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/devel/makedepend

On Mon, Jun 04, 2012 at 11:23:50AM +0200, Jörn Clausen wrote:
> What's the status of this problem? I get the same error
> checking if cc -std=gnu99 supports -Werror=implicit... no
> checking if cc -std=gnu99 supports -errwarn=E_NO_EXPLICIT_TYPE_GIVEN
> -errwarn=E_NO_IMPLICIT_DECL_ALLOWED... eval: 1: Syntax error: Bad
> substitution
> when compiling x11/libICE, and I expect similar problems on the other
> X11 packages that were recently updated. This is NetBSD 5.1.

It's a check for a Solaris compiler option which has spaces inside
(and thus in the shellscript variables) and causes problems in the
shell, due to a bug (AFAIWT).

I have no 5.1.

I see two options:
. depend on a different shell for configuring these packages
. patch the offending part out

I'd prefer the first, since it's less effort when maintaining the

Home | Main Index | Thread Index | Old Index