pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39763: www/libgtkhtml has unstated dependency upon devel/gail

>Number:         39763
>Category:       pkg
>Synopsis:       www/libgtkhtml has unstated dependency upon devel/gail
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Oct 18 18:20:01 +0000 2008
>Originator:     Robert Elz
>Release:        NetBSD 4.0_STABLE  (pkgsrc current within last 10 hours)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        It appears that www/libgtkhtml (with the default options)
        needs devel/gail installed, but doesn't request that that

        I use pkg_comp (and as it happens, this time) NetBSD 4.0 release
        sets and libkver (I doubt this is relevant, except that with
        pkg_comp it is more likely that there will be missing packages
        as the sandbox gets regularly cleaned).

        Compiling www/libgtkhtml (as a dependency of something else)
        produced ...

=> Full dependency libgtkhtml>=2.6.3nb10: NOT found
=> Verifying bin-install for ../../www/libgtkhtml
===> Binary install for libgtkhtml>=2.6.3nb10
=> Installing libgtkhtml>=2.6.3nb10 from /pkg_comp/packages/All
pkg_add: no pkg found for 'libgtkhtml>=2.6.3nb10', sorry.
pkg_add: 1 package addition failed
=> No binary package found for libgtkhtml>=2.6.3nb10; installing from source.
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for libgtkhtml-2.6.3.tar.bz2
=> Checksum RMD160 OK for libgtkhtml-2.6.3.tar.bz2
===> Installing dependencies for libgtkhtml-2.6.3nb11
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.24nb6
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency pkg-config>=0.19: found pkg-config-0.23
=> Build dependency x11-links>=0.39: found x11-links-0.39
=> Build dependency randrproto>=1.2.0: found randrproto-1.2.2
=> Build dependency renderproto>=0.9.3nb1: found renderproto-0.9.3nb1
=> Build dependency fixesproto>=3.0.0: found fixesproto-4.0
=> Build dependency inputproto>=1.4: found inputproto-1.4.4
=> Build dependency checkperms>=1.1: found checkperms-1.10
=> Full dependency libxml2>=2.6.23nb1: found libxml2-2.7.1nb1 
=> Full dependency gtk2+>=2.8.17nb1: found gtk2+-2.12.12
===> Overriding tools for libgtkhtml-2.6.3nb11
===> Extracting for libgtkhtml-2.6.3nb11
===> Patching for libgtkhtml-2.6.3nb11
===> Creating toolchain wrappers for libgtkhtml-2.6.3nb11

        [long irrelevant line deleted]

===> Configuring for libgtkhtml-2.6.3nb11
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
=> Adding run-time search paths to pkg-config files.
=> Checking for portability problems in extracted files

        [Lots of typical config noise]

creating libtool
checking for gtk+-2.0 >= 2.0.0 libxml-2.0 >= 2.4.16... yes
checking GTKHTML2_CFLAGS... -O2 -DXTHREADS -I/usr/pkg/include/gtk-2.0 
-I/usr/pkg/lib/gtk-2.0/include -I/usr/pkg/include/atk-1.0 
-I/usr/pkg/include/cairo -I/usr/pkg/include/pango-1.0 -I/usr/pkg/include 
-I/usr/X11R6/include -I/usr/pkg/include/glib/glib-2.0 
-I/usr/pkg/lib/glib-2.0/include -I/usr/pkg/include/freetype2 
-I/usr/pkg/include/libpng12 -I/usr/pkg/include/pixman-1 
checking GTKHTML2_LIBS... -Wl,-R/usr/pkg/lib -R/usr/X11R6/lib 
-Wl,-R/usr/X11R6/lib -L/usr/pkg/lib -L/usr/X11R6/lib -lgtk-x11-2.0 
-lgdk-x11-2.0 -lXi -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lXrandr -lXext 
-lXcursor -lXfixes -lcairo -lpangoft2-1.0 -lpango-1.0 -lm -lfreetype -lz 
-lfontconfig -lXrender -lX11 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl 
checking for gail >= 1.8... configure: error:
*** gail is needed for accessibility. Either install gail or turn off
*** accessibility support using the --disable-accessibility option.
*** Error code 1

make: stopped in /usr/pkgsrc/www/libgtkhtml
*** Error code 1


        According to print-build-depends-list

This package requires package(s) "Xfixes-2.0.1nb4 Xft2-2.1.7nb3 
Xrender-0.9.0nb2 atk-1.24.0 cairo-1.8.0 digest-20080510 expat-2.0.1 
fam-2.7.0nb9 fixesproto-4.0 fontconfig-2.6.0 glib2-2.18.1 glitz-0.5.6nb2 
gmake-3.81 gtk2+-2.14.3 inputproto-1.4.4 intltool-0.40.5 jpeg-6bnb4 
libtool-base-1.5.24nb6 libxml2-2.7.2nb1 p5-XML-Parser-2.36 pango-1.22.0 
pcre-7.8 perl-5.10.0nb1 pixman-0.12.0 pkg-config-0.23 png-1.2.32 
renderproto-0.9.3nb1 shared-mime-info-0.51nb1 tiff-3.8.2nb4 x11-links-0.39 
xdg-dirs-1.4 xmlcatmgr-2.2nb1" to build.

        No gail...

        Add a dependency upon gail, I assume...

Home | Main Index | Thread Index | Old Index