NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg_rolling-replace and mismatched version



It sounds like you are not having a pkg_rolling-replace problem, in that
the underlying make replace does not work.  Please see the
pkg_rolling-replace man page where it asks that problems with a make
replace (that was ordered reasonably) not be reported as
pkg_rolling-replace issues.

I would suggest checking your pkgdb (that you only have one, rebuild,
rebuild-tree, check).

Also, when you upgrade NetBSD from 9 to 10, you can run old packages,
but you cannot (soundly, in general) run a mixed package set.   So you
need to mark all packages rebuild=YES or do something equivalent.



Home | Main Index | Thread Index | Old Index